• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

New minions wont do anything and game lagging very hard in campaign

boogieguy4

Dwarven Worker
May 7, 2015
7
0
20
24
#1
minions wont do anything in mission 10 it started when my dungeon was getting bigger,
they where just standing on the unclaimed tiles and do any now and then.
they all start running over it and sometimes one just randomly starts claiming a wall or tile.
they also dont respond on the unlimited gold thing.
game also suffers from very heavy lags in almost every lvl 8 was extreme too.
and also in big fights some of my minions don't attack.
all the settings have been set a low as it could.
my laptop specs are 8 gb ram.
video card Ati Radeon Mobility HD5650
processor AMD Phenom II N930 2ghz
 

v0id

Programmer
Brightrock Games
Nov 18, 2011
2,428
1,008
580
Germany
#3
Hey boogieguy4,

I don't know why this post wasn't answered, it might have slipped through.
I am sorry for this inconvennience.

First of all, please start in future a separate thread for each unique issue you encounter.
This makes it easier for us to manage bug tickets in our system, which can then be linked to one forum thread each.

So essentially you encountered two bugs:
1) units kinda not respond/do nothing
2) "they also dont respond on the unlimited gold thing"
For the second one i am unsure what the sentence correspeonds to, but i guess you talk about a gold shrine?
In this case it might be the same issue "units kinda not respond/do nothing"

Could you elaborate a bit more sepcific what, when and how happened ?

3) And a performance issue with serious lags.

The issues you reported 1) 2) are not known and we are not sure how to reproduce.
I have never encountered something like this in recent versions of the game nor was it reported by anyone.
But maybe these problems are related to the performance issues you have as well.

Your system specs are slightly below the minimum requirements of this game.
At least your GPU is slightly below what is supported and your CPU is on the lower end of the supported ones.
So you will need to play on low settings to make it work at all.
So which options have you set?
Important are the settings under "Display Options"
I would suggest to enable V-Sync option, use lowest texture resulution, max zoom out limit to the minimum value and possession FOV to the minimum and Pixel Light Count to 1.
Also disable everything under Advanced Settings.

Does this make the game playable for you?

To figure out if the issues you encountered with units behaviour are performance related or a real game bug it would help us a lot, if you could upload an output_log.txt of a playsession where you encounter the issue.
Read here how to upload an output_log.txt: https://forum.subterraneangames.com/threads/please-read-how-to-report-a-bug.4689/
Please play the game till you encounter the issue.
Then stop the game and grab the output_log before you start the game again (otherwise it will be overwritten).

So we could have a look what was going wrong for you.

Cheers
 
Feb 9, 2014
367
120
285
#4
Hey boogieguy4,

I don't know why this post wasn't answered, it might have slipped through.
I think that is the case, as I can't remember this thread.... I probably overlooked it. :oops: I also did not encounter the above bugs so far.
 
Likes: v0id
Feb 9, 2014
367
120
285
#5
minions wont do anything in mission 10 it started when my dungeon was getting bigger,
they where just standing on the unclaimed tiles and do any now and then.
they all start running over it and sometimes one just randomly starts claiming a wall or tile.
they also dont respond on the unlimited gold thing.
game also suffers from very heavy lags in almost every lvl 8 was extreme too.
and also in big fights some of my minions don't attack.
all the settings have been set a low as it could.
my laptop specs are 8 gb ram.
video card Ati Radeon Mobility HD5650
processor AMD Phenom II N930 2ghz
And please use CAPITALS ;) next time and paragraphs as it makes text much more easy to read; just remember that for your next bug report :p And are you sure you're using a 64-bit of Windows or an other OS? :)
 

boogieguy4

Dwarven Worker
May 7, 2015
7
0
20
24
#6
Hello,

Thank you for the respond,
Sorry for my bad typing i will do my best.
I am going to try what you had suggested,
And see if it works.
And my laptop is 64 bit btw and runs windows 7

And my native language isnt english.
Sorry if my english isnt understandable:$
Il try my best.

Friendly regards, Boogieguy4
 

boogieguy4

Dwarven Worker
May 7, 2015
7
0
20
24
#7
hello,

I started the load game again with all the settings set as you said,
And it didn't change.
I did played skirmish today and that seem to run fine,
I noticed it starts doing weird things when my dungeon is very large.
And survival also workt fine

And i was wondering why the game has such high system requirements
Will that be fixed or is that just going to stay like that for the game?
Really hope it changes.
And like the game a lot beside the issues im having

Here is the output log file for the load game
 

Attachments

Feb 9, 2014
367
120
285
#8
Make sure to answer all V0ids questions and also please don't make multiple posts in a row, but try to combine them into one :)
 

v0id

Programmer
Brightrock Games
Nov 18, 2011
2,428
1,008
580
Germany
#9
hello,

I started the load game again with all the settings set as you said,
And it didn't change.
I did played skirmish today and that seem to run fine,
I noticed it starts doing weird things when my dungeon is very large.
And survival also workt fine
Hello again boogieguy4,
your log contains some strange errors which do not look normal, they could well be part of the performance issues you encounter.

Which level did you play on this play session?
Was it loaded from an (old) save game or was it a fresh start?

Maybe something broke with an recent steam update.
Could you restart your computer, run steam as administrator and verify your game cache files?
See: https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Does it change anything?

And i was wondering why the game has such high system requirements
Will that be fixed or is that just going to stay like that for the game?
Really hope it changes.
And like the game a lot beside the issues im having

Here is the output log file for the load game
We are not yet sure if your performance issues are caused by the errors in your log or by your hardware.
To some extent the performance requirements come from the Unity engine which can be quite resource hungry when you want to render graphically advanced games.
The game might not look so detailed from far but when you zoom in or possess minions you might find a lot of details and this makes it costly.
On the other hand we are just a small indie team and did not everything in the most optimized way on this project and need to do improvements on the long term.
We can only reduce the requirements step by step with optimizations, but we are looking forward to get it more down in future.
There is also hope that future Unity updates will help us to improve the overall performance of the game.
However right now you are slightly below those requirements, your system is a bit aged and it could happen that you encounter more performance problems than others.
But when you say that skirmish and survival works than it could be mainly caused by the errors in your log.
We will need to see.
 

boogieguy4

Dwarven Worker
May 7, 2015
7
0
20
24
#10
It was a old safe game
I wil try out the cache verify today and
And see if it works
Restart the mission until i run into the problem
again,
And post the output log here.

I understand.
But i heared unity was hard engine to work with,
Is that true?
And i have unity too can i use the debug mode For the game myself,
Or doesnt it work like that.

Thank you for the help i will try reply as quickly,
As possible.
And i hope you guys can pull it off
With the game.
I'm a big fan of the dk games and this feels,
Like i am playing dk once again haha.
 

boogieguy4

Dwarven Worker
May 7, 2015
7
0
20
24
#11
hello,

I verified the game cache in steam,
Started the mission again from the beginning (mission 10 the kenos btw)
From the beginning i noticed when the intro started it lagging a bit not a lot,
After i was playing for 15 minutes and my dungeon was a lot bigger.
It was getting worse till the point
The game was very slow and wasn't playable anymore like the last time,
All the minions and imps again did not respond or interact with training eating,
During fighting, claiming tiles, digging.
I could still pick them up tho.
here is the output log file for my game session.
 

Attachments

v0id

Programmer
Brightrock Games
Nov 18, 2011
2,428
1,008
580
Germany
#12
Hey again boogieguy4,
If it was an old save game it was likely this main cause of the issues, recent versions were still flawed and we changed multiple things that can make old save games unplayable.
If you start the level again it should work better again.
I see you posted again while i was writing...
Yea the level 10 is the most performance hungry level we have and you are below the minimum requirements for this game.
The only chance to get it to work in such cases it to use very low settings and close other programs while playing the game.
I would suggest to go to "Display Settings" and disable all "Advanced Settings", lower texture resolution and put the zoom out limit to a minimum.
We still work on optimizations but right now your system is not fully supported, so that you need to do some cutbacks for now.
Hope this helps!

For your Unity question:
It doesn't work like this, as the game needs to be build as debug version to apply unity debugging, but the public version isn't.
Unity is a nice tool not hard to work with but it has its edges and can reach its limits when you try to make a quite advanced game which isn't an FPS with an almost static environment.
 

boogieguy4

Dwarven Worker
May 7, 2015
7
0
20
24
#13
Hello,

Thank you i will try it out and,
Did you see anything different this time in the output log because this time i didn't used a save game,
Or did it showed the same problems as the output log before this one?>(in the last post)

If it cant be fixed ill just play the missions that i can for now
I did wondered however one thing tho is there,
A kind of way to skip that level so i can do the rest and come back to it later when i can play it,
Or isn't that possible through a command or something in a text file, or just some other way?
I'm no pro in those things so i don't know how to do it myself.
Or do i have to patiently wait till the lite version comes out?
And i have paid for the normal version would i automatically get the lite version or is it going to be separate from the normal version,
Or is the lite version of war for the overlord a rumor on itself?

Anyway thank you very much for the help and the patience i hope it will all go well with the game,
And maybe in the future we will even have a sequel to this one i hope.
Really liked the dk game series and am glad you guys brought it back after many years.
And please let me know if there is a way to bypass the level.

friendly regards boogieguy4
 
Top Bottom