1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't figure it out!

Discussion in 'Translation Questions' started by [DK]Futrik, Dec 13, 2016.

  1. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    I am trying to translate the game from english to danish, but i just can't figure out why it does'nt work. I tried to download the italian version, just to compare with mine, and in my opinion mine is quite similar.. Well except for the language.. Anyways i've tried to test it as i go, but none of my translations work.. oh and yes, i did close excel before testing.. Anyways, is it really impossible to test the translation "as you go"? because i for sure can not figure it out. BTW the template is not identical to the pictures in the Community Translation Guide, wich frankly confused me too... hence why i looked at the italian version - tried to make one similar... Guess what, it did'nt f***ing work!! No I'm not done yet, but i would be really upset if i translated 7000+ words and sentences, just to find out, it did not work.

    So please.. If i'm gonna translate it from english to danish, tell me, what i am doing wrong?!
    My patience is slipping up...
     

    Attached Files:

    Last edited: Dec 13, 2016
  2. Nutter
    Offline

    Nutter Inquisitor Founder

    Messages:
    2,414
    Likes:
    1,079
    Trophy Points:
    595
    @BlackBeard any chance you could give this guy a hand since you were the first person to get it working?
     
  3. Noontide
    Offline

    Noontide Award Winning Community Manager Dev Team

    Messages:
    2,029
    Likes:
    1,728
    Trophy Points:
    680
    I took a brief look at this before I left the office last night (11:45PM :D) I can take a deeper look at it later but I think the CSV is set up on his system to be ";" delimitted instead of "," delimited. So the game can't correctly interpret it. I didn't get a chance to try though.

    Basically there are a mass of semi-colons everywhere. I'll take a look when I'm back in today.
     
  4. BlackBeard
    Offline

    BlackBeard Bafu

    Messages:
    416
    Likes:
    84
    Trophy Points:
    250
    Blackbeard at work .... please wait:D

    EDIT:

    the cause of the problem are the errors in the spacing of the columns ...

    if you are not too far ahead with the translation I suggest you follow these steps:

    1) Use Google Drive to manage your spreadsheet
    2) Use the original format (the file is called GameText) and then continue with the translation in your language column
    3) when finished follow the guide posted by Noontide.

    personal advice:

    I do not recommend to begin the translation alone, it is a huge work for one person.
     
    Last edited: Dec 14, 2016
    Nutter likes this.
  5. BlackBeard
    Offline

    BlackBeard Bafu

    Messages:
    416
    Likes:
    84
    Trophy Points:
    250
    I tried to fix it ...
    see if it works properly ;)
     

    Attached Files:

  6. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    It works.. sort of anyways. I can see that the game implementet the translation, but all the translations were "missplaced" The game switched them around for some reason...
     
  7. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    Ok, i'll try to use the GameText instead. I only translated like 140'ish words and sentences..

    The reason i am doing it alone, is because of the fact that non of my friends play this game, and non of them are competent enough to help me out..

    Yeah, allmost all of my friends sucked in school... :rolleyes:
     
  8. BlackBeard
    Offline

    BlackBeard Bafu

    Messages:
    416
    Likes:
    84
    Trophy Points:
    250
    I am glad to have been of some help!
    yes, it is a bug :confused:
     
  9. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    Ok, i am trying to use the GameText file now, and here's what i've got so far https://docs.google.com/spreadsheets/d/17tJhPN7_Ya2Ib5Sa1y5KIYU02ZNB0_owkgmaeNPeEnQ/edit?usp=sharing Does it look right to you?

    Anyways, I wanted to test it, so i made a copy: https://docs.google.com/spreadsheets/d/1F2Heeq-97WCA_6IiNfkGTsQiNUIPuiUKjGHikfwxT38/edit?usp=sharing Where the only column left is my language. And... It does'nt work... I am following Noontide's guidlines, but for some reason it does'nt work for me.. Could you tell me if i'm doing something wrong this time?

    Oh, and BTW i am using google sheet this time.
     
  10. BlackBeard
    Offline

    BlackBeard Bafu

    Messages:
    416
    Likes:
    84
    Trophy Points:
    250
    I have the same problem, unfortunately I think it's a bug.
     
  11. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    OK, i'll just wait 'till it's fixed then. Thanks for the help anyways! ;):D
     
  12. Noontide
    Offline

    Noontide Award Winning Community Manager Dev Team

    Messages:
    2,029
    Likes:
    1,728
    Trophy Points:
    680
    Hi Guys,

    Just dropping by 5AM Now going home soon but I thought I'd give your translation file a go. The Danish file loaded fine for me. Can you give me a run down of any particular problems you've had with any of the stuff we've uploaded previously. Anything in the Guide that doesn't seem quite right and I can get it looked at.

    War For The Overworld 15_12_2016 04_56_25.png

    If there's any technical bugs that need addressing have you reported them via user echo? Can get someone to look soon if so.
     
    BlackBeard likes this.
  13. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    I can't really tell if there's any bugs, since it worked for you, but the "Translation Template" is CSV file. Because of this, people can't delete the "notes" column and it also makes the spreadsheet look different from the pictures on the "Community Translation Guide" page. excel.png
    This is what it looks like, when you open the Translation Template.CSV. I think it might confuse a few people, including me.. For now, my only report is that, i still can't get it to work. I even tried to upload it to Steam Workshop, as a private file, and download it. And i think you should upload a normal spreadsheet instead of the .CSV, whether it's an openoffice, libraoffice or an excel file..

    Another thing, could you tell me how you save your .CSV-files, and wich program you use?

    Thanks, I hope we figure something out soon..
     
  14. BlackBeard
    Offline

    BlackBeard Bafu

    Messages:
    416
    Likes:
    84
    Trophy Points:
    250
    the reason is simple ..

    when you open the CSV file you must enter the separator option .. you put the check mark for "comma" and "semicolon"

    I use LibreOffice 5.2 (updated version of OpenOffice) .. to save the file in csv just overwrite the save without making any extension changes
     
  15. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    Ok, i have downloaded libreoffice, and tried to do what you did, and I still can't get it to work... I can't tell for sure what i'm doing wrong. Noontide got it to work, so i guess i'm doing something wrong...
     
  16. BlackBeard
    Offline

    BlackBeard Bafu

    Messages:
    416
    Likes:
    84
    Trophy Points:
    250
    Charge the translation of steam workshop

    Move the translation files located in this folder
    X: \ Program Files (x86) \ steamapps \ common \ War For The Overworld \ WFTOGame_Data \ Translation \ Community

    (The folder must be empty)

    subscribe to your translation on steam workshop and see if it works.
     
  17. [DK]Futrik
    Offline

    [DK]Futrik Gnarling

    Messages:
    13
    Likes:
    1
    Trophy Points:
    50
    It worked!!! Even downloaded it as a .CSV from google sheets (the point is, i do not need libreoffice). To sum it up, I need to put the .CSV in the SteamLibrary\steamapps\common\War For The Overworld\WFTOGame_Data\Translation\Community-folder upload it to Steam Workshop, and then i have to remove the .CSV from the folder after uploading it, start up the game again, and choose my translation.

    Thanks for the help everyone!!
     
  18. BlackBeard
    Offline

    BlackBeard Bafu

    Messages:
    416
    Likes:
    84
    Trophy Points:
    250
    exact, with the hotfix That Has Been today fixed the problem at startup,
    but if you leave the files in the community folder, when You start the game you will see the standard translation, and you have to change it manually every time.

    P.S. In this way, however, you will see two translation files, one work correctly and the other does not work (the one in the community folder does not work)
     
  19. Noontide
    Offline

    Noontide Award Winning Community Manager Dev Team

    Messages:
    2,029
    Likes:
    1,728
    Trophy Points:
    680
    Few more things coming today to make the whole thing a bit more flexible. I'll be updating the template files & batch files as well for this.
     
    BlackBeard likes this.
  20. Noontide
    Offline

    Noontide Award Winning Community Manager Dev Team

    Messages:
    2,029
    Likes:
    1,728
    Trophy Points:
    680
    Ok so the hotfix is going live now. I've updated the translation guides. Template should work from the get go now, no faffing around removing columns or adding language codes.

    This is what I've changed.

    Optional: You can also enter your languages' two or three character code as defined by ISO 639-1 and ISO 639-2. This is currently not used for anything but may be used in the future. To do so replace the XX at the top of the Your Langauge Column.

    This template should be completely ready for direct upload to steam workshop.

    Your Document should be ready as soon as you have completed the file. Please ensure that your translation is in the second column of the sheet.

    Essentially your first column must contain the keys, the second column must contain your translation. Any following columns will be ignored and you can add whatever you like.
     
    BlackBeard likes this.

Share This Page