1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I select monitor?

Discussion in 'General Help & Support Legacy' started by zespri, Apr 18, 2015.

  1. zespri
    Offline

    zespri Gnarling

    Messages:
    13
    Likes:
    4
    Trophy Points:
    50
    Admittedly, I don't know a single game that allows you to select which monitor you are playing on in multi-monitor setup. However all of those game that I tried would run the game on the main monitor by default. WFTO is the only one that insist on running on the secondary monitor, and it drives me nuts, that I can't persuade it to run on the main one. Is there any trick that would allow me doing that?
    2015-04-18_22-10-41.png
     
    Last edited: Apr 18, 2015
  2. Triscopic
    Offline

    Triscopic Gargoyle Backer

    Messages:
    279
    Likes:
    110
    Trophy Points:
    310
    Interesting. I have two monitors and it always correctly runs on my main screen.

    From that screen shot it looks like your main monitor is #2, on the right. My guess is one of those two facts is your problem. Try swapping the cables around so that your right hand screen is detected as #1. Failing that try telling Windows that your rough hand monitor is on the left... Not a fix exactly buy a useful debug step for the devs if it works.

    My money is on WftO running on monitor #1 though.
     
  3. zespri
    Offline

    zespri Gnarling

    Messages:
    13
    Likes:
    4
    Trophy Points:
    50
    Yes, my monitor is #2 on the right. Swapping cables will most likely achieves nothing unfortunately, as Windows 8 is smart enough to detect that and still knows which monitor is which even with the cables swapped. It is difficult for me to physically rearrange monitors, as I want the bigger one to be my main, and the brackets (mounts) are not easily movable.

    Wrapping mouse over the wrong border of the screen is also something that I'd like to avoid.

    If I had to guess, I'd agree with you, it looks like WftO runs on monitor 1 instead of running on main. I'll experiment a bit and will report back.

    What I secretly hoped for is that there is an obscure setting in an odd config file for that.

    Turns out there some games that allows you selecting screens. Even as old as Space Empires V.
     
  4. zespri
    Offline

    zespri Gnarling

    Messages:
    13
    Likes:
    4
    Trophy Points:
    50
    So I swapped the cables. Did not touch windows settings. This is what it looks like now:
    2015-04-19_11-39-32.png
    And WftO is still displayed on the left screen.
    I'm out of ideas.
     
  5. Triscopic
    Offline

    Triscopic Gargoyle Backer

    Messages:
    279
    Likes:
    110
    Trophy Points:
    310
    Actually late last night I noticed the launcher has a specific screen selector. Run the launcher (I think it's called WftO.exe, but I might be wrong, I'm out at the moment and can't check, but it's the other exe that isn't WftOgame)

    There you'll see a box that lets you choose which screen to launch the game on
     
  6. zespri
    Offline

    zespri Gnarling

    Messages:
    13
    Likes:
    4
    Trophy Points:
    50
    My version is the steam one, there is no separate launcher. In the game folder there are two exes WFTO.exe and WFTOGame.exe. WFTO.exe does not display any UI to me, just starting up WFTOGame.exe and exiting.
     
  7. Triscopic
    Offline

    Triscopic Gargoyle Backer

    Messages:
    279
    Likes:
    110
    Trophy Points:
    310
    Hmm. I to have the stream version. I'm not sure how I got the launcher to appear... I was trying to replicate crashes last night and had quite a few. I thought the launcher was the other exe... Maybe not... A quick Google shows it is part of the WftOgame exe. Hmm. I'll try to look at it later tonight, but it's definitely the way to solve the problem.
    [​IMG]

    (Image via Google, from another post on the forum)
     
    Last edited: Apr 19, 2015
  8. LynchDev
    Offline

    LynchDev Spirit

    Messages:
    38
    Likes:
    5
    Trophy Points:
    135
    I too have this problem, my solution is just to disable the secondary monitor while playing the game.
     
  9. Triscopic
    Offline

    Triscopic Gargoyle Backer

    Messages:
    279
    Likes:
    110
    Trophy Points:
    310
    Ok. I'm stumped. I got the launcher to appear yesterday without intending to. Today I can't get it to appear at all no matter what I do.
     
  10. zespri
    Offline

    zespri Gnarling

    Messages:
    13
    Likes:
    4
    Trophy Points:
    50
    Keep "shift" key depressed while starting the game - that will make Unity launcher to appear. And yes, you can selected the monitor from the launcher and it works. So this kind of solves the problem for me. Would be nice though if game could detect the main monitor and use that by default.

    I do not like disabling second monitor solution, as I like to watch stuff (you know, IM's, emails, chats, etc) while playing.
     
  11. AvatarIII
    Offline

    AvatarIII Huntress Founder

    Messages:
    1,713
    Likes:
    766
    Trophy Points:
    570
    put this in the command line:

    http://docs.unity3d.com/Manual/CommandLineArguments.html
     
    Lord of Riva likes this.
  12. mrtnptrs
    Offline

    mrtnptrs Chunder

    Messages:
    367
    Likes:
    120
    Trophy Points:
    285
  13. Lord of Riva
    Offline

    Lord of Riva The Lord Founder

    Messages:
    2,786
    Likes:
    952
    Trophy Points:
    485
    we are also aware of this and it has been reported. We will hopefully fix this soon
     
    mrtnptrs likes this.
  14. DanMan3395
    Offline

    DanMan3395 Dwarven Worker

    Messages:
    5
    Likes:
    1
    Trophy Points:
    25
    +1 to you sir, this is the real fix.

    FYI to dev team the monitors the launcher detects use numbering that does not match the OS.
     

Share This Page