• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Notice the new look? We've updated to a new version of Xenforo, please read our latest post.

lagging demo

Jul 7, 2012
44
14
110
Belgium
#1
For some reason the demo is lagging all the time, no matter what setting I play it on. What can be the problem? It's not that my laptop is'nt strong enough... I hope this won't be the case with the actual game?:p
 
Dec 5, 2012
38
3
125
31
Poland
#2
The demo has settings? where?
It lags a bit on my Linux Box (I'd say 15-20FPS @ radeon M6370), 30FPS when impersonating an imp)
But that's probably due to the showcase having everything on that can be. And my card being only kinda ok:p
 

coolant

Dwarven Worker
Dec 12, 2012
12
0
20
subterraneangames
#3
Its your graphics cards im running on an i7 SLI BEAST which i call hurricane because that what it sounds like~ but it runs great and looks awesome.It maybe a bit too dark in some places but it looks really cool
 

coolant

Dwarven Worker
Dec 12, 2012
12
0
20
subterraneangames
#5
Have you tried running it in full screen? im using 2 GTX560 so there is a problem i know its a driver problem~...Also trying installing the newest driver for your graphic card and chipset~ And wost case is you'll have to play it on low graphics setting
 
Jul 7, 2012
44
14
110
Belgium
#9
coolant thx for info! I'll try that, but you know where I can do that by any chance?:p
and otherwise I'll have to live with it:)

and deagle275 is right, it's indeed an art ;)
 
Top Bottom