• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Laggy mouse/hand cursor & camera

Jul 5, 2015
9
3
140
#1
WFTO v1.1.15 (3rd July update)

Windows 7 32-bit
4GB Ram
Intel Core 2 Duo E7500 @ 2.93GHz
ATI Radeon HD 4300/4500 Series 1GB vRam

The mouse/hand cursor lags around 0.5-1.0 seconds behind from when I move my mouse to what is shown on screen. The top down camera also lags and is delayed in a similar way 0.5-1.0 seconds from the key press resulting in stutters and jumping of the camera. The actual gameplay runs perfectly smooth and fine with no lag, it just seems to be the mouse & camera lagging.

Many Thanks.
 

Attachments

Last edited:

Lord of Riva

The Lord
Founder
Dec 29, 2012
2,786
923
485
30
#2
Your system does not fullfill the minimum requirments of the game, from the steam store page:

  • OS:Windows 7 (64-bit), Windows 8 (64-bit)
  • Processor:Dual Core CPU @ 2.0GHz
  • Memory:6 GB RAM
  • Graphics:Nvidia GT400 series with 512MB RAM or better, ATI 4870HD with 512MB RAM or better
  • Hard Drive:4 GB available space (may increase in the future)
  • Sound:Speakers or headphones
sadly i dont think we can help you with your issue as its most likely related to that :(
im sorry for the inconvenience
 

Lord of Riva

The Lord
Founder
Dec 29, 2012
2,786
923
485
30
#4
Ok, please could you break down my Output_log so I know where the bottleneck is?
well you are using a 32-bit system which only supports 4 gb, the minimum requirements are 6 gb for which oyu need a 64-bit system (eg. Win7 64-bit)

also your GPU is under minimum specs youll need a ATI 4870HD or equivalent at minimum
 
Jul 5, 2015
9
3
140
#5
  • Major optimisations to underlying code which has resulted in significantly reduced Memory usage
    • Up to 70% Reduced memory usage in-game compared to patch 1.1.7 (1.4GB from 4.8GB)
    • Up to 83% Reduced memory usage on startup compared to patch 1.1.7 (627MB from 3.7GB)
    • Up to 76% reduced initial game startup time compared to patch 1.1.7 (5.61s from 23.50s)
So the required RAM in game is 4.8 - 1.4 = 3.4 Gb RAM

How do you not know your own patch notes?
 

Psycix

Dryad
Founder
Jan 9, 2013
834
305
395
#6
You ram should suffice, make sure you're not running the game at high texture resolutions. The ram shouldn't be the issue.
My bet is on your GPU struggling to keep up. What kind of FPS are you getting?
 

Nutter

Frost Weaver
Founder
Jan 19, 2013
2,449
1,090
615
28
Huddersfield, UK
nutter666.tumblr.com
#7
  • Major optimisations to underlying code which has resulted in significantly reduced Memory usage
    • Up to 70% Reduced memory usage in-game compared to patch 1.1.7 (1.4GB from 4.8GB)
    • Up to 83% Reduced memory usage on startup compared to patch 1.1.7 (627MB from 3.7GB)
    • Up to 76% reduced initial game startup time compared to patch 1.1.7 (5.61s from 23.50s)
So the required RAM in game is 4.8 - 1.4 = 3.4 Gb RAM

How do you not know your own patch notes?
That doesn't mean that the minimum spec requirements have changed (It's being considered, but hasn't changed yet)
 
Jan 3, 2013
3,241
739
495
30
#8
You ram should suffice, make sure you're not running the game at high texture resolutions. The ram shouldn't be the issue.
My bet is on your GPU struggling to keep up. What kind of FPS are you getting?
I'd say he should try toying with scroll speeds for camera and mouse. Maybe some values will help him a bit.
 
Jul 5, 2015
9
3
140
#9
My FPS is fine at around 20-30 fps, and I can handle like 40 minions on screen no problem. It's the UI elements that like the cursor and camera that I have problems with like I have explained.
 

Psycix

Dryad
Founder
Jan 9, 2013
834
305
395
#11
My FPS is fine at around 20-30 fps, and I can handle like 40 minions on screen no problem. It's the UI elements that like the cursor and camera that I have problems with like I have explained.
I looked up the benchmark scores for the minimum spec GFX card and yours, it doesn't match.
Despite you getting some FPS (personally I call anything below 60 not fine :p) I think that the GPU working at max load all the time is the source of these issues.
Every time I've had mouse lag in any game it was because my GPU barely pulled it, with similar FPS. Some games can run with low FPS, others get input lag, it varies per game and per system.
 
Likes: gArmour28
Jul 5, 2015
9
3
140
#13
I looked up the benchmark scores for the minimum spec GFX card and yours, it doesn't match.
Despite you getting some FPS (personally I call anything below 60 not fine :p) I think that the GPU working at max load all the time is the source of these issues.
Every time I've had mouse lag in any game it was because my GPU barely pulled it, with similar FPS. Some games can run with low FPS, others get input lag, it varies per game and per system.
Thanks for the info, but I really don't think it's the source of the problem because the GPU is under no load at all on the menu screen and I get the problem.
 

Psycix

Dryad
Founder
Jan 9, 2013
834
305
395
#15
Thanks for the info, but I really don't think it's the source of the problem because the GPU is under no load at all on the menu screen and I get the problem.
There's still stuff being rendered in the menu. What FPS are you getting there?

If you want, could you check your CPU and GPU usage percentages (and FPS) in a few situations?
The menu, sandbox, and ingame with lots of stuff going on.
 

Lord of Riva

The Lord
Founder
Dec 29, 2012
2,786
923
485
30
#16
Thanks for the info, but I really don't think it's the source of the problem because the GPU is under no load at all on the menu screen and I get the problem.
both your RAM and your GPU are under minimum specs.

what do you want to achieve with pointing these ram values out? i tested the Ram usage there and these are values we saw and may not be accurate for your system.

the minimum requirements did not change and your issue is most likely caused by your system specs. i do not particualry like you trying to be witty, thats not helpful
 
Last edited:
Jul 5, 2015
9
3
140
#18
both your RAM and your GPU are under minimum specs.

what do you want to achieve with pointing these ram values out? i tested the Ram usage there and these are values we saw and may not be accurate for your system.

the minimum requirements did not change and your issue is most likely caused by your system specs. regardless of you trying to be witty
I'm really not trying to be witty and I'm sorry if I made you mad ._. It's just that quoting the minimum specs is not telling me what the problem is Lord of Riva and just feels like your trying to get rid of me without giving a proper answer.

Anyway after running some tests and reading the output_log my self (which is meant to be for you), I can confirm the the issue is GPU related.

There's still stuff being rendered in the menu. What FPS are you getting there?

If you want, could you check your CPU and GPU usage percentages (and FPS) in a few situations?
The menu, sandbox, and ingame with lots of stuff going on.
Yeh I'm shocked that my GPU is on full load on the menu, thanks you for alerting me to the problem Psycix.

Lord of Riva is it possible for you to discuss adding a Mouse Sensitivity option in the setting with the Devs, as this would help to reduce the problem as it does with the camera sensitivity. Many Thanks.
 
Likes: Psycix

Lord of Riva

The Lord
Founder
Dec 29, 2012
2,786
923
485
30
#19
Likes: gArmour28
Top Bottom