• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Linux support has been added!

anagromataf

Warden
WFTO Backer
Dec 30, 2012
2
0
160
#3
after downloading I had to rename the WFTO_Data folder to Data in order to make it work; (did a clean download)
otherwise I'd get 'no data folder found'
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#4
after downloading I had to rename the WFTO_Data folder to Data in order to make it work; (did a clean download)
otherwise I'd get 'no data folder found'
Did you download the non-working version previously?

Edit: It appears that there's a case-sensitivity issue with the current build. You can work around it for the moment by moving the two affected folders:
Code:
mv "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/wfto.x86_64" "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64"
mv "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/UIResources" "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/uiresources"
 
Last edited:

Vašek Chromický

Dwarven Worker
WFTO Backer
Oct 24, 2013
8
1
30
Prague, Czech Republic
#5
Finally, great! Thanks!
Firstly, yes, I did have the case-sensitivity issue too.

Secondly, on my Dell XPS 13 (Intel HD Graphics 4000, Gentoo, x11-drivers/xf86-video-intel-2.20.13) all the menus and in game UI is somehow scaled down. See the attachments.

But great work. Apart from the broken menu the game seems to work (I can't build much with no menu though)! :)
 

Attachments

Flo

Oculus
Oct 24, 2013
16
1
105
32
#7
Thanks for adding Linux support!

I just bought the game to try it out. Firstly I noticed that starting it from steam does not work, because steam wants to start WFTO.x86_64 instead of wfto.x86_64.

After I renamed the data folder the game started. First the window was black and only sound was playing but then a nice looking title screen appeared. However it had no UI at all. I fixed the name of the UI folder as well, but that didn't have any effect.

Maybe the cause is that it can't find the library libwinmm.dll? The game searches for that library at a about 30 places before gives up. It's search can be visualized with:

$ strace ./wfto.x86_64 2>&1|grep libwinmm

I use Fedora 19 and a GeForce GTX 660
 

taKen

Blood Imp
Oct 24, 2013
2
0
10
30
Parts Unknown
#8
Hi! I'm currently running Steam for Linux on Ubuntu 13.10. I cannot see that Linux support has been added to War for the Overworld. There is only the Windows support according to the Steam store. Will War for the Overworld work even when Steam doesn't explicitly state that it will? All the best from Norway!
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#9
Hi Flo,

The steam configuration apparently affects both the QA build and the public build :/ Updated instructions (until the QA build is out):

Code:
mv "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/wfto.x86_64" "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64"
mv "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/UIResources" "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/uiresources"
 

Simburgur

Managing Director
Brightrock Games
Nov 10, 2011
2,864
1,979
725
27
Brighton, UK
www.twitter.com
#10
Hi Flo,

The steam configuration apparently affects both the QA build and the public build :/ Updated instructions (until the QA build is out):

Code:
mv "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/wfto.x86_64" "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64"
mv "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/UIResources" "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/uiresources"
Oops.

Pushed the fix to live.
 

taKen

Blood Imp
Oct 24, 2013
2
0
10
30
Parts Unknown
#12
Now everything works here as it should (Linux client for Steam on Ubuntu 13.10). But whenever I click on "main menu" when I want to exit a game session, WFTO crashes. Love the music btw.
 

Elear

Blood Imp
Oct 24, 2013
7
0
10
31
#13
I have the same problem as Flo above, no menu appears. Window with the game opens, I can see some part of the Underworld where stuff moves, but I cannot interact with it, and there is no menu whatsoever. I have the latest build to this moment, I've checked it with Steam's "Check integrity" option.

strace shows calls for libwinmm.dll which is missing.

Arch Linux x64 here.
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#14
I have the same problem as Flo above, no menu appears. Window with the game opens, I can see some part of the Underworld where stuff moves, but I cannot interact with it, and there is no menu whatsoever. I have the latest build to this moment, I've checked it with Steam's "Check integrity" option.
...
Hi Elear, you do not need libwinmm.dll. Could you please check that the version you downloaded has the appropriate case for the WFTO_Data and WFTO_Data/uiresources folders? You can check that quickly by executing:
Code:
ls "${HOME}/.local/share/Steam/SteamApps/common/War For The Overworld" "${HOME}/.local/share/Steam/SteamApps/common/War For The Overworld/WFTO_Data"
If you previously downloaded WFTO then it will _not_ change the case of these folders.
 

Elear

Blood Imp
Oct 24, 2013
7
0
10
31
#15
Hi Elear, you do not need libwinmm.dll. Could you please check that the version you downloaded has the appropriate case for the WFTO_Data and WFTO_Data/uiresources folders? You can check that quickly by executing:
Code:
ls "${HOME}/.local/share/Steam/SteamApps/common/War For The Overworld" "${HOME}/.local/share/Steam/SteamApps/common/War For The Overworld/WFTO_Data"
If you previously downloaded WFTO then it will _not_ change the case of these folders.
It seems that the version I have has the appropriate case for these folders (and I have no menu in the game):
Code:
$ ls "${HOME}/Steam/SteamApps/common/War For The Overworld" 
Data  WFTO.x86_64  WFTO_Data

$ ls "${HOME}/Steam/SteamApps/common/War For The Overworld/WFTO_Data"
Managed  Resources        level1  level4    resources.assets      sharedassets2.assets  sharedassets5.assets
Mono     StreamingAssets  level2  level5    sharedassets0.assets  sharedassets3.assets  sharedassets6.assets
Plugins  level0           level3  mainData  sharedassets1.assets  sharedassets4.assets  uiresources
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#16
Well that's disappointing, would you mind running "ldconfig -p | grep libudev.so.0" and sending me the output? CoherentUI runs this to determine which libudev to use for launch.
 

Elear

Blood Imp
Oct 24, 2013
7
0
10
31
#17
Apparently I only have libudev.so.1:
Code:
$ ldconfig -p | grep libudev.so
        libudev.so.1 (libc6,x86-64) => /usr/lib/libudev.so.1
        libudev.so.1 (libc6) => /usr/lib32/libudev.so.1
        libudev.so (libc6,x86-64) => /usr/lib/libudev.so
        libudev.so (libc6) => /usr/lib32/libudev.so
Thanks for trying to help, btw.

EDIT: tried making a simlink from libudev.so.0 to libudev.so.1, doesn't help.
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#18
Elear, probably the easiest way to see if that's the problem would be to make a symlink:
Code:
ln -s /usr/lib/libudev.so.1 "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/StreamingAssets/CoherentUI_Host/linux/libudev.so.0"
Please give that a try and see if it makes a difference. np ;)
 

Elear

Blood Imp
Oct 24, 2013
7
0
10
31
#19
Elear, probably the easiest way to see if that's the problem would be to make a symlink:
Code:
ln -s /usr/lib/libudev.so.1 "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/StreamingAssets/CoherentUI_Host/linux/libudev.so.0"
Please give that a try and see if it makes a difference. np ;)
Yeah, I tried that right away, doesn't help, sadly. (I tried simlinking /usr/lib/libudev.so.1 to /usr/lib/libudev.so.0, but simlinking it to "${HOME}/Steam/SteamApps/common/War For The Overworld/WFTO_Data/StreamingAssets/CoherentUI_Host/linux/libudev.so.0" doesn't help as well)
 
Top Bottom