• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Linux support has been added!

SXX

Cultist
Oct 25, 2013
7
4
180
36
#43
My 'locate' works for $HOME, too
I didn't know that, most people I know never configured it. :)

Actually you can try to find where Coherent_Host located. It's should be simple script which run Coherent_Host.bin and then you can redirect it's output where you like to. Actually it's might have different name, but should be have for same purpose.

PS: Looks like I'll buy WFTO (tomorrow might be), at least for Coherent testing. :D
 
Last edited:

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#45
I didn't know that, most people I know never configured it. :)

Actually you can try to find where Coherent_Host located. It's should be simple script which run Coherent_Host.bin and then you can redirect it's output where you like to. Actually it's might have different name, but should be have for same purpose.

PS: Looks like I'll buy WFTO (tomorrow might be), at least for Coherent testing. :D
That doesn't actually work, it may be that something needs to be compiled in to enable the debugging support.
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#46
...That means there are some issues with bumblebee. Here is the new logfile:
Code:
optirun bash -c "\"${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64\" -logfile ~/logs/wfto-optirun.log"
Found path: /home/crysman/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64
the wfto-optirun.log file is here:
http://www.uschovna.cz/en/package/M5FRV9FU5S5K5E6I-8IH
PA has a similar problem, apparently a good "test case" is running chromium with optirun. Apparently you need to run it like "primusrun chromium --enable-webgl --ignore-gpu-blacklist" in order to use WebGL. So, it's _possible_ that it might fix the problem by modifying the CoherentUI_Host script to include the "--ignore-gpu-blacklist" flag:
Code:
exec -a "$0" "$HOST_DIR/CoherentUI_Host.bin" --ignore-gpu-blacklist "[email protected]"
 

SXX

Cultist
Oct 25, 2013
7
4
180
36
#47
That doesn't actually work, it may be that something needs to be compiled in to enable the debugging support.
As I see in WFTO logs posted by crysman there is Coherent Host logs already, e.g:
Code:
[11792:11792:INFO:renderer_main.cc(215)] Running without renderer sandbox
You actually can see same error in Chrome/Chromium.

Also as long as I understand Coherent Labs do not provide any source code to game developers, so most likely both PA and WFTO use exactly same code. Can you please run WFTO and try to open this URL? Also is there any port opened by Coherent Host process while game is running?
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#48
...
This is Coherent log, you actually can see same error in Chrome/Chromium.

Also as long as I understand Coherent Labs do not provide any source code to game developers, so most likely both PA and WFTO use exactly same code. Can you please run WFTO and try to open this URL? Also is there any port opened by Coherent Host process while game is running?
Ok, then the Coherent log is interspersed with the game log when it's run with the "-logfile <file>" command line arguments ( see post #31 ). The only port Coherent is using is 9999, do you have a tool I can use to try and talk to it?
 

SXX

Cultist
Oct 25, 2013
7
4
180
36
#49
The only port Coherent is using is 9999, do you have a tool I can use to try and talk to it?
Yeah, PA developers publicly shared this tool for registered users (you don't need to own game, just make an account) in this topic:
https://forums.uberent.com/threads/ui-debugger.50276/page-2#post-798844
But actually it's just remote version of Chrome Developer Tools and only useful for in-game live UI editing and javascript debugging.
Also if you have any web server you can just upload "html" directory on it and open it with any browser which support web sockets, so you don't need to use "Debugger" executable.

I'm asked about this just to be sure that both games use same version of Coherent. :)

Sad, but it's useless for linux driver problems debugging. :(
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#50
...
I'm asked about this just to be sure that both games use same version of Coherent. :)
...
If I setup roughly the same folder structure as PA I get "Key validation failed! The system will shut down", so I doubt it. I can, however, launch it from the PA folder and then successfully use it debug WFTO (so you'd have to own PA and WFTO to use it as-is). Unfortunately, it seems that the diagnostics are more UI-focused - there do not seem to be any diagnostics that would be useful for investigating crysman's problem. I'm a little surprised I can't use it from a normal browser, but no matter where I put the html folder it won't work (when I have some more time I'll poke around a little and see if I can find out how to trick it).
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#51
...
That means there are some issues with bumblebee.
...
I've played around with bumblebee a little to see what it does (I cannot actually use it though, as I only have an nVidia card). I suspect that I may be able to reproduce your issues with VirtualGL, but in the meantime I have a suspicion about what the source of the problem may be. Would you mind sending me the output of "ls -haltF /dev/nvidiactl" ? At least on my system simply installing bumblebee screwed up the permissions on this file.

Edit: In such a way that the game does not launch ;)
 

Flo

Cultist
Oct 24, 2013
16
1
180
33
#52
Hi Flo, would you mind checking to see if "${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libudev.so.0" exists? If so, you could try removing the system-wide library you added and symlinking that one instead. If that works then that's something that can be used to fix this problem in a more generic way.
Hi Flo, would you mind checking to see if "${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libudev.so.0" exists? If so, you could try removing the system-wide library you added and symlinking that one instead. If that works then that's something that can be used to fix this problem in a more generic way.
I uninstalled the libudev package and tried to symlink it instead. It works too. I used the following command to create the symlink:
ln -s "${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libudev.so.0 /usr/lib64/libudev.so.0"
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#53
I uninstalled the libudev package and tried to symlink it instead. It works too. I used the following command to create the symlink:
ln -s "${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libudev.so.0 /usr/lib64/libudev.so.0"
Hi Flo, that's great news! Would you mind removing that symlink, double checking that that breaks the game, and then placing it in the game folder instead?:
ln -s "${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libudev.so.0" "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO_Data/StreamingAssets/CoherentUI_Host/linux/libudev.so.0"
 
Likes: Flo

Flo

Cultist
Oct 24, 2013
16
1
180
33
#54
Yes, I double checked it again. It breaks the game and using your game directory symlink instead works too.
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#55
Yes, I double checked it again. It breaks the game and using your game directory symlink instead works too.
Awesome, would you mind trying one more thing? Could you remove the symlink (make sure it breaks) and then try running the following?:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu"
"${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64"
 

Flo

Cultist
Oct 24, 2013
16
1
180
33
#56
Awesome, would you mind trying one more thing? Could you remove the symlink (make sure it breaks) and then try running the following?:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu"
"${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64"
No, that doesn't work: The menu won't become visible.

Btw. have you any idea why the sound doesn't work when I start it via steam?
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#57
No, that doesn't work: The menu won't become visible.
...
Hmm, that's odd - when I removed the library on my system (to break it) and then tried that it worked... Would you mind pasting the output of "echo $LD_LIBRARY_PATH" after trying those commands?

...
Btw. have you any idea why the sound doesn't work when I start it via steam?
1) Please try right-clicking on the game in your Steam library, go to "Properties" and then click "Set Launch Options".
2) Inside the text box type/paste:
-logfile ${HOME}/wfto-debug.log
3) Click "OK" and then click "CLOSE".
4) Launch the game, wait for it load up, then exit.
5) Send me the log file (wfto-debug.log) that appears in your home directory.
 

Erich Hoover

Linux Wizard
WFTO Founder
Mar 11, 2013
80
35
260
#58
No, that doesn't work: The menu won't become visible.

Btw. have you any idea why the sound doesn't work when I start it via steam?
Interestingly, a little investigation shows that Steam already sets up the LD_LIBRARY_PATH with its libraries, so both problems you're experiencing may be a failing of the libraries that Valve provides. If I had to guess then I'd guess that Steam is suggesting an ALSA or PulseAudio sound library version that isn't compatible with your kernel.
 

Flo

Cultist
Oct 24, 2013
16
1
180
33
#60
That trick with steam is sweet! I created a log file as you suggested. It seems like I have the same issue decribed in this bug report: https://github.com/ValveSoftware/steam-for-linux/issues/2924

About the console launch:
If I run the following command before setting LD_LIBRARY_PATH, I get the following result:
Code:
$ ldd ~/.local/share/Steam/SteamApps/common/War\ For\ The\ Overworld/WFTO_Data/StreamingAssets/CoherentUI_Host/linux/CoherentUI_Host.bin |grep udev
  libudev.so.0 => not found
  libudev.so.1 => /lib64/libudev.so.1 (0x0000003a10a00000)
After the setting LD_LIBRARY_PATH, I get the following result:
Code:
$ ldd ~/.local/share/Steam/SteamApps/common/War\ For\ The\ Overworld/WFTO_Data/StreamingAssets/CoherentUI_Host/linux/CoherentUI_Host.bin |grep udev
  libudev.so.0 => /home/flo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libudev.so.0 (0x00007fc604f9e000)
  libudev.so.1 => /lib64/libudev.so.1 (0x0000003a10a00000)
$ echo $LD_LIBRARY_PATH
:/home/flo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu
This time it crashed, when I tried after the export for the first time to start WFTO:

Code:
$ "${HOME}/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64"
Found path: /home/flo/.steam/steam/SteamApps/common/War For The Overworld/WFTO.x86_64
Mono path[0] = '/home/flo/.local/share/Steam/SteamApps/common/War For The Overworld/WFTO_Data/Managed'
Mono path[1] = '/home/flo/.local/share/Steam/SteamApps/common/War For The Overworld/WFTO_Data/Mono'
Mono config path = '/home/flo/.local/share/Steam/SteamApps/common/War For The Overworld/WFTO_Data/Mono/etc'
Aborted (core dumped)
At the second, third and fourth time it didn't crash but didn't show a menu either.
 
Top Bottom