• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solution for: UI does not show or game is very slow

Cultist Joris

Ember Demon
WFTO Founder
Dec 30, 2012
1,555
840
545
25
Belgium
#1
Problem

  • When launching the game, you do not see any UI or the Main Menu.
or

  • The game appears to run very slow at all times, consistently.
Solution

  • Both of these problems can be attributed to PC's with two graphics cards, one of which is an NVidia or AMD GPU - Many machines, specially laptops, have a default onboard Intel GPU as well as a more powerful discrete GPU (Nvidia or AMD).
  • The Nvidia drivers have an application called Nvidia Optimus that controls when the more powerful Nvidia GPU is turned on and used.
  • The AMD drivers have as application called Switchable Graphics that controls when the more powerful AMD GPU is turned on and used.
  • Sometimes this does not correctly happen for some games.

Follow the instructions below based on what GPU you have (Nvidia or AMD).

How to force the more powerful AMD GPU to turn on:

  1. First, go to the AMD website and download and install the latest drivers for your GPU
  2. Right click on your desktop -> Select "AMD Catalyst Control Center"
    This should open your graphics card control panel
  3. Select "Power" -> "Switchable Graphics Application Settings"
    In the page displayed, press „Add Application“
  4. Navigate to …/Steam/steamapps/common/War For The Overworld
  5. Select the WFTOGame.exe
  6. You should now see WFTO in the list of applications
  7. Change the graphics setting in the list to „High performance“
  8. Launch and enjoy the game!

How to force the more powerful NVidia GPU to turn on:

  1. First, go to the NVidia website and install the latest drivers for your GPU
  2. Right click on your desktop -> Select "NVIDIA Control Panel"
    This should open your graphics card control panel
  3. Select "3D settings" -> "Manage 3D settings" -> "Program settings"
  4. Click on the „Add“ Button and navigate to …/Steam/steamapps/common/War For The Overworld
  5. Select the WFTOGame.exe and press „Open“
  6. You should now be able to select WFTOGame.exe in the first dropdown menu
  7. Select „High-performance NVIDIA processor“ in the second dropdown menu
  8. Launch and enjoy the game!
 

Attachments

Last edited by a moderator:
May 30, 2015
27
5
70
29
#2
Any solutions when the options refuse to change? When I change the settings and apply, it changes them back as soon as the screen changes or I exit and re-enter the settings screen.
 

strich

Lead Programmer
Brightrock Games
Nov 30, 2012
180
63
260
32
#3
If the settings keep resetting, try the following:
  1. Go to C:\Program Files\NVIDIA Corporation\Control Panel Client\
  2. Locate nvcplui.exe.
  3. Right click it -> Properties -> compatibility -> check Run this program as administrator.
Try the instructions in the first post again.
 
May 30, 2015
27
5
70
29
#4
It still changes back like before, could it be conflicting programs?

some specifications of my laptop:

Windows 8.1 64

Intel® Core™ i7 processor

Intel® Core™ i7-5500U met Intel HD Graphics 5500 (2,4 GHz, 4 MB cache, 2 cores)

16 GB 1600-MHz DDR3L SDRAM (2 x 8 GB)

39,6-cm (15,6-inch) diagonal HD BrightView WLED-backlit (1366 x 768)

NVIDIA GeForce 840M (4 GB DDR3 reserved)
 
May 30, 2015
27
5
70
29
#6
Thanks for the help anyway. I googled before asking here (I find it rude not to) but all the solutions were pretty far-reaching (uninstalling and reinstalling system software etc..) So I think I'll just have to wait until 1.1 stable version releases.
 

strich

Lead Programmer
Brightrock Games
Nov 30, 2012
180
63
260
32
#7
Thanks for the help anyway. I googled before asking here (I find it rude not to) but all the solutions were pretty far-reaching (uninstalling and reinstalling system software etc..) So I think I'll just have to wait until 1.1 stable version releases.
The issue is that I'm not sure if v1.1 stable will fix it - The problem stems from the 3D engine (Unity3D) we use, and we don't have much access to its internals.

My guess is that some power management software installed with your laptop is enforcing those nvidia settings.

I'll raise a bug ticket with Unity3D, but they can take many weeks to get things fixed sadly.
 
May 30, 2015
27
5
70
29
#8
Just to be clear, I do not have the problem with the 1.0 version right now. In case the information is relevant. I'll try looking for the power management software, but I think that would be windows itself.
 

strich

Lead Programmer
Brightrock Games
Nov 30, 2012
180
63
260
32
#12
I have googled about the problem, and I found this: https://forums.geforce.com/default/topic/762829/nvidia-control-panel-won-t-save-settings-/?offset=4

I'm all for solutions but this one seems a bit far going. Could anyone glance over this and see if this thing makes sense in my context?
Unfortunately it does appear that your laptop has some kind of bad installation configuration. I wouldn't suggest pulling apart your laptop, if that is what you're thinking.
 
May 30, 2015
27
5
70
29
#13
So I should find someone who knows how to handle installation configuration then.

I was certainly not about to pull apart my laptop as it would remove my guarantee of 3 years on it.
 
May 30, 2015
27
5
70
29
#14
Good news: NVIDIA updated today and now I can change the setting. Now I can see the UI on the menu and ingame.

The warning about my processor (your graph settings are not set to the right processor or something) still pop ups when starting the game, however.
 
Likes: Emre

strich

Lead Programmer
Brightrock Games
Nov 30, 2012
180
63
260
32
#15
Good news: NVIDIA updated today and now I can change the setting. Now I can see the UI on the menu and ingame.

The warning about my processor (your graph settings are not set to the right processor or something) still pop ups when starting the game, however.
It might give a false positive on the first run. Can you confirm that it pops up every time for you?
 

strich

Lead Programmer
Brightrock Games
Nov 30, 2012
180
63
260
32
#17
You were right, it didn't pop up the second time.
Good to hear. Thanks to NVidia there isn't really an easy way for us to detect problems for you. So the work around we have isn't perfect, but it at least helps you.
 
Apr 4, 2015
28
10
115
#18
How to force the more powerful AMD GPU to turn on:
  1. First, go to the AMD website and download and install the latest drivers for your GPU.
  2. Right click on your desktop -> Select "AMD Catalyst Control Center"
    This should open your graphics card control panel.
  3. Select "Power" -> "Switchable Graphics".
    In the page displayed, disable Switchable Graphics.
  4. Launch the game to test.
You say that, and AMD says I got the latest version...

But the Catalyst Control Center says "Nope, you won't have that 'power' option there..."

pls help.

 

strich

Lead Programmer
Brightrock Games
Nov 30, 2012
180
63
260
32
#19
You may not be suffering from switchable graphics problems then. What is your issue exactly?
 
Jun 21, 2015
3
0
15
#20
I tried all of these workarounds and I still get no menu. Before this update I was able to see the menus and play the game. Trying the NVidia fixes don't save \ work. Neither do setting the launch options. Please fix what worked before.
 
Top Bottom